According to the minimum technical requirements, we support the following web browsers:


Browser
NameVersion
Google Chrome
Latest available.
Check version: chrome://settings/help
Microsoft EdgeLatest available.
Check version: edge://settings/help



Note: any other browsers are not supported by Examus so we can't guarantee that proctoring will work correctly in them.

Need further assistance? Reach out to us via support@examus.com or our support portal so that we can help you.